Computer & RF Technology

gnuradio 3.7をHomebrewでMac OSXにインストールする

さて、gqrxをソースからビルドしたいのですが、gqrxは内部でgnuradioを使用しています。最初インストール済だったgnuradio 3.6でgqrxをビルドしようとしたのですが、エラーで失敗してしまいました。最新のgqrxはgnuradio 3.7が必須なようです。これを機会にgnuradioのバージョンを3.7に上げることにしました。現在の最新版gnuradio-3.7.2.1を使用することにします。せっかくなのでbrewのFormulaを修正して、gnuradio 3.7をbrewでインストールできるようにしてみます。さらにbladerfの対応も付け加えたいと思います。 image